Error while deploying Rails API mode


#1
Bundle complete! 84 Gemfile dependencies, 228 gems now installed.
Use `bundle info [gemname]` to see where a bundled gem is installed.
=> cd /tmp/jets/turbo-wrapper-project/rack && bundle exec rake assets:clobber --trace
rake aborted!
Don't know how to build task 'assets:clobber' (See the list of available tasks with `rake --tasks`)
/home/josue/.rvm/gems/ruby-2.5.3/gems/rake-12.3.2/lib/rake/task_manager.rb:59:in `[]'
/home/josue/.rvm/gems/ruby-2.5.3/gems/rake-12.3.2/lib/rake/application.rb:159:in `invoke_task'
/home/josue/.rvm/gems/ruby-2.5.3/gems/rake-12.3.2/lib/rake/application.rb:116:in `block (2 levels) in top_level'
/home/josue/.rvm/gems/ruby-2.5.3/gems/rake-12.3.2/lib/rake/application.rb:116:in `each'
/home/josue/.rvm/gems/ruby-2.5.3/gems/rake-12.3.2/lib/rake/application.rb:116:in `block in top_level'
/home/josue/.rvm/gems/ruby-2.5.3/gems/rake-12.3.2/lib/rake/application.rb:125:in `run_with_threads'
/home/josue/.rvm/gems/ruby-2.5.3/gems/rake-12.3.2/lib/rake/application.rb:110:in `top_level'
/home/josue/.rvm/gems/ruby-2.5.3/gems/rake-12.3.2/lib/rake/application.rb:83:in `block in run'
/home/josue/.rvm/gems/ruby-2.5.3/gems/rake-12.3.2/lib/rake/application.rb:186:in `standard_exception_handling'
/home/josue/.rvm/gems/ruby-2.5.3/gems/rake-12.3.2/lib/rake/application.rb:80:in `run'
/home/josue/.rvm/gems/ruby-2.5.3/gems/rake-12.3.2/exe/rake:27:in `<top (required)>'
/home/josue/.rvm/gems/ruby-2.5.3/bin/rake:23:in `load'
/home/josue/.rvm/gems/ruby-2.5.3/bin/rake:23:in `<top (required)>'
/home/josue/.rvm/rubies/ruby-2.5.3/lib/ruby/site_ruby/2.5.0/bundler/cli/exec.rb:74:in `load'
/home/josue/.rvm/rubies/ruby-2.5.3/lib/ruby/site_ruby/2.5.0/bundler/cli/exec.rb:74:in `kernel_load'
/home/josue/.rvm/rubies/ruby-2.5.3/lib/ruby/site_ruby/2.5.0/bundler/cli/exec.rb:28:in `run'
/home/josue/.rvm/rubies/ruby-2.5.3/lib/ruby/site_ruby/2.5.0/bundler/cli.rb:463:in `exec'
/home/josue/.rvm/rubies/ruby-2.5.3/lib/ruby/site_ruby/2.5.0/bundler/vendor/thor/lib/thor/command.rb:27:in `run'
/home/josue/.rvm/rubies/ruby-2.5.3/lib/ruby/site_ruby/2.5.0/bundler/vendor/thor/lib/thor/invocation.rb:126:in `invoke_command'
/home/josue/.rvm/rubies/ruby-2.5.3/lib/ruby/site_ruby/2.5.0/bundler/vendor/thor/lib/thor.rb:387:in `dispatch'
/home/josue/.rvm/rubies/ruby-2.5.3/lib/ruby/site_ruby/2.5.0/bundler/cli.rb:27:in `dispatch'
/home/josue/.rvm/rubies/ruby-2.5.3/lib/ruby/site_ruby/2.5.0/bundler/vendor/thor/lib/thor/base.rb:466:in `start'
/home/josue/.rvm/rubies/ruby-2.5.3/lib/ruby/site_ruby/2.5.0/bundler/cli.rb:18:in `start'
/home/josue/.rvm/rubies/ruby-2.5.3/lib/ruby/gems/2.5.0/gems/bundler-1.17.2/exe/bundle:30:in `block in <top (required)>'
/home/josue/.rvm/rubies/ruby-2.5.3/lib/ruby/site_ruby/2.5.0/bundler/friendly_errors.rb:124:in `with_friendly_errors'
/home/josue/.rvm/rubies/ruby-2.5.3/lib/ruby/gems/2.5.0/gems/bundler-1.17.2/exe/bundle:22:in `<top (required)>'
/home/josue/.rvm/gems/ruby-2.5.3/bin/bundle:23:in `load'
/home/josue/.rvm/gems/ruby-2.5.3/bin/bundle:23:in `<main>'
cd /tmp/jets/turbo-wrapper-project/rack && bundle exec rake assets:clobber --trace failed to run.
/home/josue/.rvm/gems/ruby-2.5.3/gems/jets-1.5.1/lib/jets/builders/code_builder.rb:231:in `rails_assets'

#2

@josuetex Thanks for asking about this.

Created an GitHub Issue for this https://github.com/tongueroo/jets/issues/141


#3

Hi @tung, Thank very much!


#4

@josuetex Fixed and released in v1.5.3 CHANGELOG

Also demo at https://rails-api.demo.rubyonjets.com/