Unable to autoload constant Concerns::ExceptionHandler

bug

#1

I created a Jets Application using CMD:jets new jwt_auth --mode api --no-database --no-webpack and added an external JWT gem to gemfile.
Things are working as expected on local server but when I am trying to deploy it then it is giving following error:

Unable to autoload constant Concerns::ExceptionHandler, expected ~/jets/jwt-authentication/app/controllers/concerns/exception_handler.rb to define it

Error evaluating ERB template on line 5 of: ~/gems/2.5.0/gems/jets-1.8.11/lib/jets/builders/templates/handler.rb
1 require “bundler/setup”
2 require “jets”
3 Jets.once # runs once in lambda execution context
4
5 <% @vars.functions.each do |function_name|
6 handler = @vars.handler_for(function_name)
7 meth = handler.split(’.’).last
8 -%>
9 def <%= meth -%>(event:, context:)
10 Jets.process(event, context, “<%= handler -%>”)

I tried adding exception_handler.rb in autoload etc but nothing helped me.
Any help from your side will be great.
Thanks


#2

Thanks for the details. Fix here: https://github.com/tongueroo/jets/pull/257 Released in v1.9.1