Lambda and API Gateway not being generated


#1

I have everything set up properly I’m able to create new posts and use CouldWatch however I do not see any of the generated lamdas nor do I see any info in the API gateway portal. Am I missing some config?

Jets deploy is supposed to create the corresponding AWS Lambda Functions and API Gateway resources So I’m not sure where these are at?

Thanks,

Jeremiah


#2


#3

@jeremiahlukus Umm. If you can create posts then it sounds like the Lambda functions and API Gateway resources exists.

Taking a stab at this. Wondering if you’re perhaps in another AWS region in the console vs the terminal. Can you double check that the AWS console is in the same AWS region as the CLI. You can switch AWS regions with the dropdown menu in the AWS console.

aws-region-dropdown

From the CLI you can check via:

$ aws configure get region
us-west-2
$

No Cloudwatch Logs
#4

You can then search for Lambda in the Service dropdown menu


#5

Just made sure, I have the correct region (I tried all of them just to make sure it didnt go into a random region)

aws configure get region
us-east-1

Which is N. Virginia.
I did the same for gateway and that is not it either. Any other ideas?


#6


#7

Odd. Try this command and see what it returns.

aws lambda list-functions

#8

Ahh hahaha I’m creating them under my work account!
Thank you! I’m demoing this to my team tomorrow wanted to get this out.


#9

Awesome. Glad you sorted it out!


#10

One last thing, now that i redeployed using another set of keys Im getting a timeout error after I configure the security settings to allow any inbound traffic. Any ideas on this?


#11

What’s the stack trace look like? Wondering if the timeout on the RDS database call?

If it’s on the database call this might help: MySQL Connection Timing out on AWS Lambda?


#12

Looks like the RDS was removed probably an admin removing a db called test. Anyway thank you for your hep it should be fine once i get it back up.