Init error when loading handler


#1

From yesterday evening my Web App in all environments including Production has stopped working.
I haven’t deployed any new changes for the last 10 days.
indent preformatted text by 4 spaces
current versions:
Ruby: 2.5.7
Jets: master branch

Please find the log below:

2020-08-07T00:00:52.110000+00:00 2020/08/06/[$LATEST]d3c351f2ea7442898551867c8d5b7ea8 START RequestId: 2802e899-5331-4f78-88a6-bec6bfc2e8e5 Version: $LATEST 2020-08-07T00:00:52.408000+00:00 2020/08/06/[$LATEST]d3c351f2ea7442898551867c8d5b7ea8 Init error when loading handler handlers/controllers/menus_controller.index 2020-08-07T00:00:52.408000+00:00 2020/08/06/[$LATEST]d3c351f2ea7442898551867c8d5b7ea8 { 2020-08-07T00:00:52.408000+00:00 2020/08/06/[$LATEST]d3c351f2ea7442898551867c8d5b7ea8 “errorMessage”: “You have already activated json 2.3.1, but your Gemfile requires json 2.3.0. Prepending bundle exec to your command may solve this.”, 2020-08-07T00:00:52.408000+00:00 2020/08/06/[$LATEST]d3c351f2ea7442898551867c8d5b7ea8 “errorType”: “InitGem::LoadError”, 2020-08-07T00:00:52.408000+00:00 2020/08/06/[$LATEST]d3c351f2ea7442898551867c8d5b7ea8 “stackTrace”: [ 2020-08-07T00:00:52.408000+00:00 2020/08/06/[$LATEST]d3c351f2ea7442898551867c8d5b7ea8 “/var/runtime/gems/bundler-2.1.4/lib/bundler/runtime.rb:312:in check_for_activated_spec!'", 2020-08-07T00:00:52.408000+00:00 2020/08/06/[$LATEST]d3c351f2ea7442898551867c8d5b7ea8 "/var/runtime/gems/bundler-2.1.4/lib/bundler/runtime.rb:31:inblock in setup’”, 2020-08-07T00:00:52.408000+00:00

Any help in fixing this issue will be very much appreciated.

Thank you in advance.


#2

Wondering if you have another gem that requires json. This will mean the Gemfile.lock has json in it. Would take a look at Gemfile.lock and make sure you remove any gems result in a json dependency. Related:

And:

Think what’s happening is the AWS Lambda Runtime enforces a specific version of JSON and that prevent Ruby from loading. Seems like AWS is rolling out updates to their AWS Lambda on more customer accounts.


#3

That’s disappointing.
I can see a json (2.3.0) dependency in Gemfile.lock file.
Thank you for the quick help.