Could not find http-parser-1.2.1 in any of the sources

bug

#1

Hey, just started using jets for a project of mine, I am using the http gem to make network requests and get the following error after deploy succeeds and I visit the site:

Could not find http-parser-1.2.1 in any of the sources.

Appreciate any help, thanks!


#2

@tung any help here would be much appreciated, I really want to start using jets and I can’t deploy at the minute without this error.

Thanks!


#3

Thanks for the report. Dug into this. Turned out to be the way jets-gems handles binary gem detection. Fixed it in https://github.com/tongueroo/jets-gems/pull/2

Do a bundle update or generate a new Jets project and it should work.


#4

Thank you so much! That’s working perfectly now :slight_smile: